(POJ2387)Til the Cows Come Home-最短路徑

Til the Cows Come Home

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 76378   Accepted: 25413

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

題目大意:模板題。給出不同路徑之間的距離,問從起點1到終點n的最短路徑長度。

spfa+鏈式前向星存儲圖:

#include<iostream>
#include<queue>
#define max_n 200010
using namespace std;
typedef long long LL;
int head[max_n], dis[max_n];
int t,v, cnt;
struct node {
	int to;
	int next;
	int cost;
}edge[max_n];

void addedge(int u, int v, int cot) {
	edge[cnt].to = v;
	edge[cnt].next = head[u];
	edge[cnt].cost = cot;
	head[u] = cnt++;
}

void spfa(int x) {
	queue<int> q;
	dis[x] = 0;
	q.push(x);
	while (!q.empty())
	{
		int ant = q.front();
		q.pop();
		int u = head[ant];
		for (int i = u; i != -1; i = edge[i].next) {
			int res = dis[ant] + edge[i].cost;
			if (res < dis[edge[i].to])
			{
				dis[edge[i].to] = res;
				q.push(edge[i].to);
			}
		}
	}
	cout << dis[v] << endl;
}

int main() {
	while (cin >> t >> v)
	{
		cnt = 0;
		memset(head, -1, sizeof(head));
		memset(dis, 1000000, sizeof(dis));
		while (t--) {
			int p1, p2, cos;
			cin >> p1 >> p2 >> cos;
			addedge(p1, p2, cos);
			addedge(p2, p1, cos);
		}
		spfa(1);
	}
	return 0;
}

dij的代碼給個鏈接:https://blog.csdn.net/qq_21057881/article/details/50563541

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章