题目483:Nightmare

题目链接:

http://acm.nyist.net/JudgeOnline/problem.php?pid=483

描述

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius’ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius’ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

输出

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

样例输入

2
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3

样例输出

4
-1

题目中文描述

简单翻一下就是给一个二维数组,从2开始,3结束,规定最多能走5步,每次只能从上下左右移动一步,1表示有路,0表示墙(不能走),4表示“补血”走的步数置0。问最少需要多少步可以走到出口,如若不能,输出1.

算法思想:

因为要遍历所有的路径,这样才能寻找到最少的步数,故使用深度搜索。唯一需要特殊考虑的是遇到4的时候,需要将血补满。这里还需要使用一个二维数组将每个点所走的最少步数记录了下来,深度搜索,填充该表即可。
注意:网上有些可以AC的代码使用的是广度搜索,是带有一个能回溯的广度搜索,有些是存在问题的,个人测试了一下,当遇到有多个4的时候,其中有些4是必须要走,有些4是不需要走的,这个时候广度优先是会有问题的,之所以能AC,说明测试用例太少。

源代码

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int map[10][10], Time[10][10], N, M, ans;
int dir[4][2] = { { 1, 0 }, { -1, 0 }, { 0, 1 }, { 0, -1 } };
void DFS(int x, int y, int n, int time)
{
    if (Time[x][y] >= time)
        return;
    if (!map[x][y])
        return;
    if (map[x][y] == 3)
    {
        ans = min(ans,n);
        return;
    }
    if (map[x][y] == 4)
        time = 6;
    int temp = Time[x][y];
    Time[x][y] = time;
    n++;
    int r, c;
    for (int i = 0; i < 4; i++)
    {
        r = x + dir[i][0], c = y + dir[i][1];
        DFS(r, c, n, time - 1);
    }
    Time[x][y] = temp;
}
int main()
{
    int T;
    int x, y;
    cin >> T;
    while (T--)
    {
        cin >> N >> M;
        ans = 9999999;
        memset(map, 0, sizeof(map));
        memset(Time, 0, sizeof(Time));
        for (int i = 1; i <= N; i++)
        {
            for (int j = 1; j <= M; j++)
            {
                cin >> map[i][j];
                if (map[i][j] == 2)
                    x = i, y = j;
            }
        }
        DFS(x, y, 0, 6);
        if (ans == 9999999)
            cout << "-1" << endl;
        else
            cout << ans << endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章