HUNNU oj 11757 Brackets————區間dp (括號匹配)

We give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

思路:

題目大意是,給出一行由括號組成的字符串,找出最長可以匹配的括號的長度。
對於五個樣例,最長分別是:
((()))
()()()
([])

([][])
思路其實在題幹中已經有所提示,即:
1.如果s是匹配的,那麼(s)或者[s]也是匹配的
2.如果a和b是匹配的,那麼ab也是匹配的
對於要求2,解決方法就是dp區間模板中的狀態轉移方程,
dp[i][j] = max( dp[i][j], dp[i][k] + dp[k+1][j]);
然後,考慮要怎麼實現要求1,其實就是還要多考慮一種情況,那種情況就是要求一的情況。在分段之前,如果出現這種情況就先把他算進dp[i][j],參與最大值的判斷

if((a[i] == '(' && a[j] == ')') || (a[i] == '[' && a[j] == ']'))
{
                dp[i][j] = dp[i+1][j-1] + 2;
}

AC代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define MAXN 105
#define INF 0x3f3f3f3f

using namespace std;

int main()
{
    char a[MAXN];
    int i, j, k, n, len, dp[MAXN][MAXN];
    while(scanf("%s", a) != EOF)
    {
        if(strcmp(a, "end") == 0)
        {
            break;
        }
        memset(dp, 0, sizeof(dp));
        for(len = 2; len <= strlen(a); len++)
        {
            for(i = 0; i <= strlen(a)-1; i++)
            {
                int j = i+len-1;
                if(j > strlen(a)-1) break;
                if((a[i] == '(' && a[j] == ')') || (a[i] == '[' && a[j] == ']'))
                {
                    dp[i][j] = dp[i+1][j-1] + 2;
                }
                for(k = i; k < j; k++)
                {
                    dp[i][j] = max(dp[i][j], dp[i][k]+dp[k+1][j]);
                }
            }
        }
        printf("%d\n", dp[0][strlen(a)-1]);
    }

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章