hdu 1150 Machine Schedule————匈牙利算法模板題

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.


Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.


Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output

4
 

思路:

匈牙利算法模板題。

 

AC代碼:

#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>

#define MAXN 1005
#define INF 0x3f3f3f3f

using namespace std;

int n, m, k;
int match[MAXN];
bool edge[MAXN][MAXN], vis[MAXN];

int dfs(int u) {
	for (int i = 1; i <= m; i++) {
		if (vis[i] == false && edge[u][i] == true) {
			vis[i] = true;
			if (match[i] == 0 || dfs(match[i])) {
				match[i] = u;
				return 1;
			}
		}
	}
	return 0;
}

int main() {
	while (scanf("%d", &n) != EOF && n) {
		scanf("%d%d", &m, &k);
		memset(match, 0, sizeof(match));
		memset(edge, false, sizeof(edge));
		for (int i = 1; i <= k; i++) {
			int a, b, t;
			scanf("%d%d%d", &t, &a, &b);
			edge[a][b] = true;
		}
		int sum = 0;
		for (int i = 1; i <= n; i++) {
			memset(vis, false, sizeof(vis));
			if (dfs(i)) {
				sum++;
			}
		}
		printf("%d\n", sum);
	}
	

	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章