HDU 1083 COURSES————匈牙利算法 + 判斷

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:


  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student 1 1 Student 1 2 ... Student 1 Count1
Count2 Student 2 1 Student 2 2 ... Student 2 Count2
...
CountP Student P 1 Student P 2 ... Student P CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

 

思路:

先用匈牙利算法求出最大匹配數。因爲要求所有課程都要匹配一名同學,所以判斷匹配數是否等於課程數p,如果等於則可以,否則不可以。

 

AC代碼:

#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>

#define MAXN 505
#define INF 0x3f3f3f3f

using namespace std;

int n, p;
bool edge[MAXN][MAXN], vis[MAXN];
int match[MAXN];

int dfs(int u) {
	for (int i = 1; i <= n; i++) {
		if (vis[i] == false && edge[u][i] == true) {
			vis[i] = true;
			if (match[i] == 0 || dfs(match[i])) {
				match[i] = u;
				return 1;
			}
		}
	}
	return 0;
}

int main() {
	int T;
	scanf("%d", &T);
	while (T--) {
		memset(edge, false, sizeof(edge));
		memset(vis, false, sizeof(vis));
		memset(match, 0, sizeof(match));
		scanf("%d%d", &p, &n);
		for (int i = 1; i <= p; i++) {
			int t;
			scanf("%d", &t);
			for (int j = 1; j <= t; j++) {
				int u;
				scanf("%d", &u);
				edge[i][u] = true;
			}
		}
		int sum = 0;
		for (int i = 1; i <= p; i++) {
			memset(vis, false, sizeof(vis));
			if (dfs(i)) {
				sum++;
			}
		}
		//printf("%d\n", sum);
		if (sum == p) {
			printf("YES\n");
		}
		else {
			printf("NO\n");
		}
	}

	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章