hdoj 1312 下棋(遞歸問題)

   


Red and Black

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 71   Accepted Submission(s) : 65
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 


AC 碼


#include<stdio.h>
#include<algorithm>
#include<string.h>
#define max 1001
using namespace std;
int n,m,x,y,i,j;
int cnt;
char a[50][50];
void f(int x,int y)
{
	if(x<1||x>m||y<1||y>n)  
	return ;
	if(a[x][y]=='#')
	return ;
	a[x][y]='#';  //當它走過的時候必須標記 
	cnt++;
	f(x+1,y);  //注意這四個遞歸的應用,原來都沒有見過 
	f(x-1,y);
	f(x,y-1);
	f(x,y+1);
}
int main()
{   
	while(scanf("%d%d",&n,&m),n|m)
	{ 	  cnt=0;
		for(i=1;i<=m;i++)
	   { 
	   	getchar();
	 	for(j=1;j<=n;j++)
	 	{
	 		scanf("%c",&a[i][j]);
	 		if(a[i][j]=='@')
	 		{
			 x=i,y=j;   //搜索@並標記 
			}	 	
	 	}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章