hdoj 1969 分蛋糕問題(二分法的應用)


這道題是典型的二分問題,由於沒有看到其中的一個已知條件分給每個人的蛋糕必須是整個大塊的,不能東拼西湊出來的)

題目意思我過生日請了f 個朋友來參加我的生日party,m個蛋糕,我要把它平均分給每個人(包括我),並且每個人只能從一塊蛋糕得到自己的那一份,並且分得的蛋糕大小要一樣,形狀可以不一樣,每塊蛋糕都是圓柱,高度一樣。

此題是一個二分題,下限是用最大的分,上限是sum/f+1。中間值是m,當cnt+=cnt+=(int)floor(p[i]/m);cnt<f+1,則r=m;否則l=m;

Pie

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 190   Accepted Submission(s) : 72
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case: ---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. ---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
25.1327 3.1416 50.2655
 
  AC碼如下
#include<stdio.h>
#define pi acos(-1.0)
#include<math.h>
int m,n,i,f,R;
double a[10010];
double mid;
int main()
{
	
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d%d",&n,&f);
		f++;
		double max=0,s=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&R);
			a[i]=pi*R*R;
			s=s+a[i];      
			if(max<=a[i])
			max=a[i];     
		}
		double l=max/f ;   //最多每人分得的蛋糕量 
		double r=s/f ; 	  //最少每人分得的蛋糕量
		
		while(r-l>=1e-5)
		{   int cnt=0;
			mid=(l+r)/2;
 		    for(i=0;i<n;i++)
			cnt=cnt+(int)(a[i]/mid);  //這個就是判斷到底能不能夠分給n個人 
			if(cnt<f)                
			 r=mid;
			else
			 l=mid;
		}
	printf("%.4lf\n",mid);	//注意這個返回值,只能是l mid 
	}
	return 0;
}

解決本題的關鍵是: 1、找到最少和最多每個人分的蛋糕量。
                                2、 用每人分得的蛋糕量夠不夠分給n個人作爲判斷
3、設置累加計算最多能分給幾根人

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章