HDOJ Humble Numbers(java)

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16520    Accepted Submission(s): 7168


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
分析:本題是求解整數範圍內前5842個醜數(只包含素數因子2,3,5,7),主要是迭代循環依次求解這5842個醜數,求第i個醜數f(i),它等於前i-1個醜數中的一個乘以素數數組中的某一個,其實就是將前i-1個數分別與素數因子相乘,然後得出比第i-1個醜數大但是最小的值作爲第i個醜數!
AC代碼(java):
import java.util.Scanner;

/**
 * 尋找醜數問題
 * @author Administrator
 *
 */
public class Main {


	public static void main(String[] args) {
		
		Scanner in = new Scanner(System.in);
		long[] array = new long[5845];
		int[] prime = {2,3,5,7};
		array[1] = 1;
		for(int i=2; i<=5842; i++){
			
			array[i] = Integer.MAX_VALUE;
			for(int j=0; j<4; j++){
				
				for(int k=i-1; k>=1; k--){
					
					if(array[k]*prime[j] <= array[i-1])
						break;
					if(array[k]*prime[j] < array[i]){
						array[i] = array[k]*prime[j];
					}
						
						
				}
				
			}
			
		}
		while(in.hasNext()){
			
			int n = in.nextInt();
			if(n == 0)
				break;
			
			if(n%10 == 1 && n%100 != 11){
				System.out.println("The "+n+"st humble number is "+array[n]+".");
			}else if(n%10 == 2 && n%100 != 12){
				System.out.println("The "+n+"nd humble number is "+array[n]+".");
			}else if(n%10 == 3 && n%100 != 13){
				System.out.println("The "+n+"rd humble number is "+array[n]+".");
			}else{
				System.out.println("The "+n+"th humble number is "+array[n]+".");
			}
		}
		
		
	}

}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章