POJ 3280 Cheapest Palindrome區間dp

Cheapest Palindrome
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
題意:給你一個串,花最少的代價讓它變成迴文串,每一個字符的插入刪除代價已經列出來了
思路:
1,首先對於一個字符,如果它沒有匹配,有兩種選擇,插入&&刪除都是可行的,那麼一定是從這兩個代價中選擇最小的那一個。
2,這題是個區間dp,枚舉區間後有兩個狀態轉移:
a:dp[i][j]=min(dp[i+1][j]+cost[str[i]-'a'],dp[i][j-1]+cost[str[j]-'a']);
若不匹配,對於區間兩側的字符要麼刪除,要麼插入,選一個代價最小的。
b:if (str[i]==str[j])dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
如果匹配了,那麼直接等於i+1...j-1區間的值即可

<span style="background-color: rgb(255, 255, 255);">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 2005 ;
char str[maxn] ;
int dp[maxn][maxn] ;
int cost[30] ;
int n,m;
int main() {
    while(~scanf("%d%d",&n,&m)) {
        scanf("%s",str) ;
        for(int i=1; i<=n; i++) {
            char a[3];
            int b,c;
            scanf("%s%d%d",a,&b,&c) ;
            cost[a[0]-'a']=min(b,c);
        }
        for (int i = m - 1; i >= 0; --i) {
            for (int j = i + 1; j < m; ++j) {
                dp[i][j]=min(dp[i+1][j]+cost[str[i]-'a'],dp[i][j-1]+cost[str[j]-'a']);
                if (str[i]==str[j]) {
                    dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
                }
            }
        }
        printf("%d\n",dp[0][m-1]);
    }
    return 0;
}</span>




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章