acm 3 1005 monkey

1.1005

2.

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.


The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 


They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 


Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 
Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 
Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 
Source
University of Ulm Local Contest 1996
 
Recommend

JGShining

3.題目:給出長方體,向上堆,猴子要喫上面的食物,儘量堆高
要求下面的塊的要比上面的大(長和寬),注意注意種長方體所給量都是無限的TT

4.動態規劃

5.#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[111];
struct ck
{
    int c;
    int k;
    friend bool operator < (const ck &a,const ck &b)
    {
        if(a.c>b.c) return true;
        if(a.c==b.c&&a.k>b.k) return true;
        return false;
    }
};
struct rx
{
    ck num;
    int len;
    friend bool operator < (const rx &a,const rx &b)
    {
        return a.num<b.num;
    }


}arr[100005];
void paopao(int &a,int &b,int &c)
{
    int t;
    if(a<b)
    {
        t=a;
        a=b;
        b=t;
    }
    if(a<c)
    {
        t=a;
        a=c;
        c=t;
    }
    if(b<c)
    {
        t=b;
        b=c;
        c=t;
    }
    return ;
}
int main()
{
    int i,n,a,b,c,j;
   // freopen("r.txt","r",stdin);
    int cass=0;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        cass++;
        int pp=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            paopao(a,b,c);
            arr[pp].num.c=b;arr[pp].num.k=c;arr[pp++].len=a;
            arr[pp].num.c=a;arr[pp].num.k=c;arr[pp++].len=b;
            arr[pp].num.c=a;arr[pp].num.k=b;arr[pp++].len=c;
        }
        sort(arr,arr+pp);
       // for(i=0;i<pp;i++)
           // cout<<arr[i].num.c<<" "<<arr[i].num.k<<endl;


        for(i=0;i<pp;i++) dp[i]=arr[i].len;
        for(i=pp-2;i>=0;i--)
            for(j=i+1;j<pp;j++)
            {
               if(arr[i].num.c>arr[j].num.c&&arr[i].num.k>arr[j].num.k)//最大遞減dp
                   if(dp[i]<dp[j]+arr[i].len)
                       dp[i]=dp[j]+arr[i].len;
            }
            int sumh=dp[0];
            for(i=0;i<pp;i++)
                if(sumh<dp[i]) sumh=dp[i];
            printf("Case %d: maximum height = %d\n",cass,sumh);




       /* int dp[10005]={0};
        int temp;
        dp[0]=arr[0].len;
        for(i=1;i<pp;i++)
        {
            temp=-32768;
            for(j=0;j<i;j++)
            {
                if(arr[j].num.c>arr[i].num.c&&arr[j].num.k>arr[i].num.k)
                {
                    temp=max(temp,dp[j]);
                }
            }
            dp[i]=arr[i].len+temp;
            //cout<<dp[i]<<endl;
        }
        temp=-32768;
        for(i=0;i<pp;i++)
        {
            if(dp[i]>temp)
                temp=dp[i];
        }
        cout<<"Case "<<cass<<": maximum height = ";
        cout<<temp<<endl;*/
    }


    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章