線段樹——Can you answer these queries?

線段樹——Can you answer these queries?

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

分析

這題是對區間的操作,詢問一段區間的值或是將區間內每個點開根號,但要注意查詢區間 [ l , r ],不一定是 l > r 的。

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
const int maxn=1e5+10;
ll f[maxn];
struct node{
	ll l,r,sum;
}a[maxn*4];
void build(ll k,ll l,ll r)
{
	a[k].l=l;
	a[k].r=r;
	if(l==r){
		a[k].sum=f[l];
		return ;
	}
	ll mid=(l+r)>>1;
	build(k<<1,l,mid);
	build(k<<1|1,mid+1,r);
	a[k].sum=a[k<<1].sum+a[k<<1|1].sum;
}
void update(ll k,ll l,ll r)
{
	if(a[k].sum==r-l+1){
		return ; //當數爲1時,就不用開方了,開方比較慢 
	}
	if(a[k].l==a[k].r){
		a[k].sum=(ll)sqrt(a[k].sum);
		return ; 
	}
	ll mid=(a[k].l+a[k].r)>>1;
	if(r<=mid){
		update(k<<1,l,r);
	}
	else if(l>mid){
		update(k<<1|1,l,r);
	}
	else{
		update(k<<1,l,mid);
		update(k<<1|1,mid+1,r);
	}
	a[k].sum=a[k<<1].sum+a[k<<1|1].sum;
}
ll query(ll k,ll l,ll r)
{
	if(a[k].l==l&&a[k].r==r){
		return a[k].sum;
	}
	ll mid=(a[k].l+a[k].r)>>1;
	ll s=0;
	if(r<=mid){
		return query(k<<1,l,r);
	}
	else if(l>mid){
		return query(k<<1|1,l,r);
	}
	else{
		s=query(k<<1,l,mid);
		s+=query(k<<1|1,mid+1,r);
		return s;
	}
}
int main()
{
	ll n,m;
	ll cnt=0;
	while(scanf("%lld",&n)!=EOF){
		cnt++;
		printf("Case #%lld:\n",cnt);
		for(int i=1;i<=n;i++){
			scanf("%lld",&f[i]);
		}
		build(1,1,n);
		scanf("%lld",&m);
		for(int i=0;i<m;i++){
			ll q,b,c;
			scanf("%lld%lld%lld",&q,&b,&c);
			if(b>c){
				swap(b,c);
			}
			if(q==0){
				update(1,b,c);
			}
			else{
				printf("%lld\n",query(1,b,c));
			}
		}
		printf("\n");
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章