poj 3071 Football (概率DP水题)

G - Football
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2nvalues; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题目:有2^n个队,相邻的两两打淘汰赛,,求最后哪个队夺冠的概率最大。
题解:dp[i][j]表示第i轮的时候,第j去支队伍赢的概率。那么dp[i][j]的前提就是i-1轮的时候,
   j是赢的,而且第i轮赢了对方接下来就是找到第i轮的时候,他的可能队手

   通过二进制可以发现规律,所有高位是一样的,第i位刚好相反,

   所以用位运算可以巧妙解决,见代码

   dp[i][j]=sigma(dp[i-1][j]*dp[i-1][k]*p[j][k])

   每经过一轮会淘汰掉一半的人,所以可以右移一位,即除以二求概率。

   具体的解释请看代码注释。O(∩_∩)O

#include <iostream>
#include <string.h>
using namespace std;
double dp[8][200];
double p[200][200];
int main()
{
    int n,ans;
    while(cin>>n)
    {
        if(n==-1)
            break;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<(1<<n);i++)//2^n支队伍
        for(int j=0;j<(1<<n);j++)
        cin>>p[i][j];
        for(int i=0;i<(1<<n);i++)
        dp[0][i]=1;
        for(int i=1;i<=n;i++) //n次比赛
        for(int j=0;j<(1<<n);j++)//注意这里跑的核心是j 而且j只跑了一次
        for(int k=0;k<(1<<n);k++)//这里是左移 代表队伍数 
        if(((j>>(i-1))^1)==(k>>(i-1))) //这里是右移 代表每次淘汰一半人
        //这个if的意思是奇数只和上一个数比而偶数只和下一个数比
        //异或一可以让奇数减一 偶数加一
        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k]; //别忘了加号 是把概率加起来
        double max=-1;
        /*for(int j=0;j<(1<<n);j++)
            cout<<dp[n][j]<<endl;*/ //输出各队胜率
        for(int j=0;j<(1<<n);j++) //选择胜率最高的那个队伍
        if(dp[n][j]>max)
        {
            max=dp[n][j];
            ans=j+1;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章