Seeding

Problem Description
It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares. Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.
Tom wants to seed all the squares that do not contain stones. Is it possible?

Input
The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. ‘S’ is a square with stones, and ‘.’ is a square without stones.
Input is terminated with two 0’s. This case is not to be processed.

Output
For each test case, print “YES” if Tom can make it, or “NO” otherwise.

Sample Input
4 4
.S..
.S..
….
….
4 4
….
…S
….
…S
0 0

Sample Output
YES
NO

#include<stdio.h>
char a[7][7];
int n,m,num,flag;
int u[4]={0,1,0,-1};
int v[4]={1,0,-1,0};
int can(int x,int y)
{
    if(x<1||x>n)
    return 0;
    if(y<1||y>m)
    return 0;
    if(a[x][y]=='S')
    return 0;
    return 1;    
}
void dfs(int x,int y)
{
    int i;
    if(num==0)
    {
        flag=1;//這裏不用flag換成int型返回值爲一就會出錯 
        return ;
    }
    for(i=0;i<4;i++)
    {
        int tx=x+u[i];
        int ty=y+v[i];
        if(can(tx,ty))
        {
            a[tx][ty]='S';
            num--;
            dfs(tx,ty);
            a[tx][ty]='.';
            num++;
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m),n)
    {
        flag=0;
        num=n*m;
        for(i=1;i<=n;i++)
        {
            getchar();
            for(j=1;j<=m;j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='S')
                num--; 
            }
        } 
        num--;
        a[1][1]='S';
        dfs(1,1);
        if(flag)
        printf("YES\n");
        else
        printf("NO\n");

    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章