hdoj 1005 Number Sequence (找規律,打表)

                               Number Sequence

                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                          Total Submission(s): 104109    Accepted Submission(s): 25211


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5
 


AC  CODE:

#include<stdio.h>
#include<string.h>
int f[1000]={0,1,1};
int main()
{
	int a,b,n,i,j;
	while(scanf("%d%d%d",&a,&b,&n),a||b||n)
	{
		for(i=3;i<1000;i++)
		{
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			if(f[i]==1&&f[i-1]==1)
			break;
		}
		i=i-2;
		n%=i;
		if(!n)
		printf("%d\n",f[i]);
		else
		printf("%d\n",f[n]);
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章