hdu 5241__Friends

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 582    Accepted Submission(s): 293


Problem Description
Mike has many friends. Here are nine of them: Alice, Bob, Carol, Dave, Eve, Frank, Gloria, Henry and Irene. 

Mike is so skillful that he can master n languages (aka. programming languages).

His nine friends are all weaker than he. The sets they can master are all subsets of Mike's languages.

But the relations between the nine friends is very complex. Here are some clues.

1. Alice is a nice girl, so her subset is a superset of Bob's.
2. Bob is a naughty boy, so his subset is a superset of Carol's.
3. Dave is a handsome boy, so his subset is a superset of Eve's.
4. Eve is an evil girl, so her subset is a superset of Frank's.
5. Gloria is a cute girl, so her subset is a superset of Henry's.
6. Henry is a tall boy, so his subset is a superset of Irene's.
7. Alice is a nice girl, so her subset is a superset of Eve's.
8. Eve is an evil girl, so her subset is a superset of Carol's.
9. Dave is a handsome boy, so his subset is a superset of Gloria's.
10. Gloria is a cute girl, so her subset is a superset of Frank's.
11. Gloria is a cute girl, so her subset is a superset of Bob's.

Now Mike wants to know, how many situations there might be.
 

Input
The first line contains an integer T(T20) denoting the number of test cases.

For each test case, the first line contains an integer n(0n3000), denoting the number of languages.

 

Output
For each test case, output ''Case #t:'' to represent this is the t-th case. And then output the answer.
 

Sample Input
2 0 2
 

Sample Output
Case #1: 1 Case #2: 1024
 

Source
 


神奇的題,開始猜的是n的10次方,然後掛了,看了題解後發現他們通過輸入輸出發現應該是32的n次方(怎麼看出來的QAQ)。總之懂了題意就是一道大數乘法題目,後來發現遇到的大數題也不少了,於是決定學有關這方面的java,看了這位的java大數水題,並查了各種函數的用法終於算是能用java解決一些問題了。以下是代碼:

/* package whatever; // don't place package name! */

import java.util.*;
import java.lang.*;
import java.io.*;
import java.math.BigInteger;

/* Name of the class has to be "Main" only if the class is public. */
public class Main
{
	public static void main (String[] args) 
	{
		Scanner cin = new Scanner(System.in);
		int t = cin.nextInt();
		int cas=1;
		for(int i=1;i<=t;i++) {
			int n = cin.nextInt();
			BigInteger ans = BigInteger.ONE;
			for(int j=1;j<=n;j++) {
				ans=ans.multiply(BigInteger.valueOf(32));
			}
			System.out.printf("Case #%d: ",cas);
			System.out.println(ans);
			cas++;
		}
	}
}

ps:裝了好久沒裝上eclipse,是我臉黑嘛= =於是找了這個在線java編譯運行的網站搞的
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章