poj 1163__The Triangle(dp)

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41674   Accepted: 25203

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

IOI 1994


#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int n,m;
    int a[110][110],dp[110][110];
    while(~scanf("%d",&n)) {
        for(int i=1;i<=n;i++) {
            for(int j=1;j<=i;j++) {
                scanf("%d",&a[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++) {
            for(int j=1;j<=i;j++) {
                dp[i][j]=max(dp[i-1][j-1],dp[i-1][j])+a[i][j];
            }
        }
        int MAX=-1;
        for(int i=1;i<=n;i++) {
            if(MAX<dp[n][i]) {
                MAX=dp[n][i];
            }
        }
        printf("%d\n",MAX);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章