[DP]poj1836

Description
In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , … , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line’s extremity (left or right). A soldier see an extremity if there isn’t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input
On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output
The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

題意:
求單調上升/單調下降/凸型的序列的最大個數。
顯然前兩種情況是最後一種的特殊情況,可以歸爲一類來做。
做法就是枚舉峯值+LIS

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
#define read freopen("q.in","r",stdin)
#define LL long long
#define maxn 1006
#define mod 100000007
using namespace std;
double a[maxn];
int up[maxn],down[maxn];

int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)scanf("%lf",&a[i]);

    for(i=1;i<=n;i++)
    {
        up[i]=1;
        for(j=i-1;j>=1;j--)
        {
            if(a[i]>a[j])
            {
                up[i]=max(up[i],up[j]+1);
            }
        }
    }
    for(i=n;i>=1;i--)
    {
        down[i]=1;
        for(j=i+1;j<=n;j++)
        {
            if(a[i]>a[j])
            {
                down[i]=max(down[i],down[j]+1);
            }
        }
    }
    int res=0;
    for(i=1;i+1<=n;i++)
    {
        for(j=i+1;j<=n;j++)
        res=max(res,up[i]+down[j]);
    }

    cout<<n-res<<endl;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章