HDU 5761 Rower Bo(多校3)

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1087    Accepted Submission(s): 401
Special Judge


Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0a1000v1,v2,100a,v1,v2 are integers
 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 104, your solution will be accepted.
 

Sample Input
2 3 3 2 4 3
 

Sample Output
Infinity 1.1428571429
 題解:

代碼:
#include <algorithm>
#include <iostream>
#include <numeric>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <cstdio>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const LL Max = (1LL<<32) - 1;
const double esp = 1e-6;
const double PI = 3.1415926535898;
const int INF = 0x3f3f3f3f;
using namespace std;

int main(){
    int a,v1,v2;
    while(~scanf("%d %d %d",&a,&v1,&v2)){
        if(a == 0)
            printf("0\n");
        else if(v1 <= v2)
            printf("Infinity\n");
        else
            printf("%.10f\n",(double)v1*a / (v1*v1-v2*v2));
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章