Oil Deposits (深搜)

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

sample input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

sample output

0
1
2
2

題意:這題可以說是搜索中最基礎的一題之一。 要找出相連在一起的有多少塊, 
分析:依次枚舉,遇到@時就進行搜索,用深搜,廣搜應該都行,目的是把相連的@都標記爲已訪問。
下面給出用DFS的代碼,最坑的是最後還有一個換行 ,要用\n或者%*c。

#include<cstdio>  
#include<cstring>  
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
char map[105][105],mat[105][105],vis[105][105];  
void dfs(int i,int j)  
{  
    if(vis[i][j]||mat[i][j]=='*')  
    return ;  
    vis[i][j]=1;  
    dfs(i-1,j-1);  
    dfs(i-1,j);  
    dfs(i-1,j+1);  
    dfs(i,j-1);  
    dfs(i,j+1);  
    dfs(i+1,j-1);  
    dfs(i+1,j);  
    dfs(i+1,j+1);  
}  
int main()  
{  
    int n,m;  
    while(~scanf("%d %d\n",&n,&m))  
    {  
        memset(map,0,sizeof(map));  
        memset(mat,'*',sizeof(mat));  
        memset(vis,0,sizeof(vis));  
        int i,j,cnt = 0;  
        if(!m&&!n)  
        break;  
        for(i = 0;i<n;i++)  
        {  
            for(j = 0;j<m;j++)  
            {  
                scanf("%c",&map[i][j]);  
                mat[i+1][j+1]=map[i][j];  
            }  
            getchar();  
        }  
        for(i = 1 ;i<=n;i++)  
        {  
            for(j = 1;j<=m;j++)  
            {  
                if(!vis[i][j]&&mat[i][j] == '@')  
                {  
                    dfs(i,j);  
                    cnt++;  
                }  
            }  
        }  
        printf("%d\n",cnt);  
    }  
}  


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章