Robberies (01揹包問題)

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this. 

input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.Notes and Constraints

0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
 
0.06 3
2 0.03
2 0.03
3 0.05
 
0.10 3
1 0.03
2 0.02
3 0.05
 
Sample Output
2
4
6
題意:有一個人想要搶劫銀行,每家銀行都具有一定的金額和被抓到的概率,知道他被抓的最大概率,求他在被抓的情況下,搶劫最多能有多少金額。
分析:被抓概率可以轉換成安全的概率,他的安全概率在大於1-P時都是安全的。就是一個01揹包的變種。搶劫的金額爲0時,肯定是安全的,所以d[0]=1,其他金額初始爲最危險的所以概率全爲0。
注意:精度如果只是兩位的話會WA,這題要注意精度問題
#include<iostream> 
#include<cstring>  
#include<algorithm>
using namespace std;
int main()
{
   int t,n,i,j,k,M,m[105];
   double q[105],f[10005],p;
   scanf("%d",&t);
   while(t--)
   {
       M=0;
       memset(f,0,sizeof(f));
       scanf("%lf %d",&p,&n); 
       for(i=1;i<=n;i++)
       {
	      cin>>m[i]>>q[i];
          M=M+m[i];
       }
       f[0]=1;
       for(i=1;i<=n;i++)
       {
	       	for(j=M;j>=m[i];j--)
	       f[j]=max(f[j],f[j-m[i]]*(1-q[i])); //揹包 
       }
       for(i=M;i>=0;i--)
       {
       if(f[i]>=1-p)
       {
           printf("%d\n",i);
           break;
       }
       }
   }
 }



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章