UVa10815 - Andy's First Dictionary- 字符串(map的使用)-難度2

題目鏈接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1756



Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

代碼+思路

/*重點:
 *1.每次輸入一個字符,對字符進行判斷,是字母加入一個單詞,別的省略
 *2.使用了stl的map,把字符串與整數映射在一起,用來查重
 *3.使用stl sort排序
 */
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <cctype>
#include <map>
#include <algorithm>
using namespace std;


map<string, int> M;
vector<string> V;

int main()
{
#ifdef LOCAL
	freopen("f:\\input.txt", "r", stdin);
	//freopen("f:\\output.txt", "w", stdout);
#endif
	string s;
	char m;
	int flag = 0;
	int count = 0;
	while(scanf("%c", &m) != EOF)
	{
		if(flag == 0 && isalpha(m))
		{//如果單詞是字母但是flag == 0,表示這是單詞的第一個字母
			flag = 1;
			s.clear();
			s.push_back(tolower(m));
		}
		else if(flag == 1 && isalpha(m))
		{//如果單詞是字母,flag == 1,表示這個是單詞的中間字母
			s.push_back(tolower(m));
		}
		else if(flag == 1 && !isalpha(m))
		{//如果單詞不是字母,flag == 1表示單詞輸入結束了輸入了別的字符
			flag = 0;
			if(M.find(s) == M.end())
			{
				M[s] = count++;//map 映射
				V.push_back(s);
			}
		}
	}
	sort(V.begin(), V.end());// 排序
	for(int i = 0; i != V.size(); ++i)
		cout << V[i] << endl;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章