POJ水題1007DNA Sorting

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 91275 Accepted: 36661
Description
One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequenceZWQM” has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted” to least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from
most sorted” to “least sorted”. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Source
East Central North America 1998

數據結構:每個串跟一個逆序數關聯,用結構體就行。
算法:數據規模不大,暴力模擬即可。
用sort按逆序數排序,因爲sort是基於快排的,排序過程主要的就是交換實現,然而如果兩個數相同,不會交換兩個數的順序,因此如果某兩個串的逆序數相同,它們在結果中當然按輸入順序

//244K  16MS
#include<cstdio>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
struct _DNA{
int InverNum;
int Order;
    char str[55];
}DNA[105]; 
int GetInver(char s[]){
    int sum=0;
    for(int i=0;i<n;i++){
        for(int j=i;j<n;j++){
            if(s[j]<s[i])sum++;
        }
    }
    return sum;
}
bool cmp(_DNA a,_DNA b){
    return a.InverNum==b.InverNum? a.Order<b.Order:a.InverNum<b.InverNum;
}
int main(){
    cin>>n>>m;
    for(int i=0;i<m;i++){
        scanf("%s",&DNA[i].str);
        DNA[i].InverNum=GetInver(DNA[i].str); 
DNA[i].Order=i;
    }
    sort(DNA,DNA+m,cmp);
    for(int i=0;i<m;i++){
        printf("%s\n",DNA[i].str);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章