全排列POJ1256Anagram

Anagram
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18690 Accepted: 7602
Description
You are to write a program that has to generate all possible words from a given set of letters.
Example: Given the word “abc”, your program should - by exploring all different combination of the three letters - output the words “abc”, “acb”, “bac”, “bca”, “cab” and “cba”.
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
Input
The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.
Output
For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.
Sample Input
3
aAb
abc
acba
Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa
Hint
An upper case letter goes before the corresponding lower case letter.
So the right order of letters is ‘A’<’a’<’B’<’b’<…<’Z’<’z’.
Source
Southwestern European Regional Contest 1995

本題是全排列,難點是將字母與相應的數字關聯,並通過字母快速獲取對應的數字: A=1,B=3,C=5,D=7……a=2,b=4,c=6,d=8……

 #include <iostream>
#include <cstring>
#include<cstdio>
#include <algorithm>
using namespace std;
int rank[300];
bool cmp(char a, char b){
    return rank[a]<rank[b];
}
int main(){
     freopen("input.txt","r",stdin);
    freopen("output.txt","w",stdout);
    int t,i,len;
    char str[20];
    for (i=0; i<=26; i++){
        rank[i+'A'] = i*2;
        rank[i+'a'] = i*2+1;
    }
    scanf("%d", &t);
    while(t--){
        scanf("%s", str);
        len = strlen(str);
        sort(str, str+len, cmp);
        do
        {
            printf("%s\n", str);
        }while(next_permutation(str, str+len, cmp));
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章