hdu 1078 FatMouse and Cheese (搜索+dp)

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

題意:一個矩形的分割成很多網格,每個格子裏都有食物,老鼠初始位置在(0,0),每次最多走k步,而且必須滿足下一步到達的格子裏面的食物大於當前,求最多能得到多少食物。
分析:用dp[i][j]記錄從(i,j)開始能得到的最多的食物,則
dp[i][j]=max(dp[i+move[][0]*c][j+move[][1]*c])+map[i][j],其中move表示移動方向

代碼:
#include<stdio.h>
#include<string.h>
#define N 101
int max(int a,int b)
{
       if(a>b)
             return a;
       return b;
}
int n,k,map[N][N],dp[N][N];
int move[][2]={0,1,1,0,0,-1,-1,0};
int dfs(int x,int y)
{
    if(dp[x][y])
        return dp[x][y];
    int i,j,a,b;
    int num=0;
    for(i=1;i<=k;i++)
    {
        for(j=0;j<4;j++)
        {
            a=x+move[j][0]*i;
            b=y+move[j][1]*i;
            if(a>=0&&a<n&&b>=0&&b<n&&map[a][b]>map[x][y])
                num=max(num,dfs(a,b));
        }
    }
    return dp[x][y]=num+map[x][y];
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        int i,j;
        if(n==-1&&k==-1)
              break;
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                scanf("%d",&map[i][j]);
        memset(dp,0,sizeof(dp));
        dfs(0,0);
        int sum=0;
        for(i=0;i<n;++i)
            for(j=0;j<n;++j)
                sum=max(sum,dp[i][j]);
        printf("%d\n",sum);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章