hdu Free DIY Tour (旅行商問題)

Problem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

很容易想到狀態轉移方程:dp[i]=max(dp[j])+num[i],j是可以到達i的城市,即j是i的前驅,然後用一個數組pre[]記錄路徑,pre[i]=j

代碼:
#include<stdio.h>
#include<string.h>
int dp[105],num[105],map[105][105],pre[105],rank[105];
int main()
{
       int n,m,k,i,j,t,cas=1,cnt,a,b,flag=0;
       scanf("%d",&t);
       while(t--)
       {
              scanf("%d",&n);
              memset(num,0,sizeof(num));
              memset(dp,0,sizeof(dp));
              memset(map,0,sizeof(map));
              for(i=0;i<=n+1;i++)
                 pre[i]=i;
              for(i=1;i<=n;i++)
                  scanf("%d",&num[i]);
              scanf("%d",&m);
              for(i=1;i<=m;i++)
              {
                     scanf("%d%d",&a,&b);
                     map[a][b]=1;
              }
              for(i=2;i<=n+1;i++)
                for(j=1;j<i;j++)
                   if(map[j][i])
                   {
                          if(dp[i]<dp[j]+num[i])
                          {
                                 dp[i]=dp[j]+num[i];
                                 pre[i]=j;
                          }
                   }
                   if(flag)
                      printf("\n");
                   printf("CASE %d#\n",cas++);
                   printf("points : %d\n",dp[n+1]);
                   cnt=0;
               for(i=n+1;i>1;i=pre[i])
                   rank[cnt++]=pre[i];
                   printf("circuit : ");
               for(i=cnt-1;i>=0;i--)
                   printf("%d->",rank[i]);
                   printf("1\n");
                   flag=1;
       }
       return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章