ACM暑期集訓 同餘定理+逆元 練習題 一個大數對一個數取餘

ppt內容

大數取模
一個大數對一個數取餘,可以把大數看成各位數的權值與個
位數乘積的和。
比如1234 = ((1 * 10 + 2) * 10 + 3) * 10 + 4,對這個數進
行取餘運算就是上面基本加和乘的應用。
代碼實現
int len = a.length();
int ans = 0;
for(int i = 0; i < len; i++){
ans = (ans * 10 + a[i] - ’0’) mod b;
}

E - Integer Divisibility

 

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

題意:給定兩個數n,d,d是一位數字,問最小的能整除n且只含數字d的數是幾位數。

思路:從後先前分析:隨意給定一個只含d的數,這個數可以分爲兩部分的和:一部分是能被n整除的,另一部分對n的餘數。如果這個數不能被n整除,那麼這個數就要再多一位了,就等於把現在的數*10+d,現在能被n整除的部分乘10以後依然能被n整除,那麼我們就只需考慮現餘數的部分了,只要現在餘數的部分乘以10+d能被n整除就找到了這個數

代碼:

#include <stdio.h>
typedef long long ll;//要用long long型 
int main()
{
	ll t,k=0;
	scanf("%lld",&t);
	while(t--)
	{
		ll n,d,z=1,i;//z初值等於1 
		k++;
		scanf("%lld%lld",&n,&d);
		ll r=d;
		while(r%n)
		{
			z++;
			r=r%n*10+d;//改變的是r,d是一個定值 
		}
		printf("Case %lld: %lld\n",k,z); 
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章