B. Matrix(二維樹狀數組)

B. Matrix

3000ms
3000ms
65536KB
64-bit integer IO format: %lld      Java class name: Main
Font Size:
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

只會簡單的一維情況,變了一點就不會了,看了大牛的代碼才知道該怎麼寫。。
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
using namespace std;
int a[1010][1010];
int n;
int lowbit(int x)
{
    return x&(-x);
}
int update(int x,int y,int data)
{
    int temp;
    while(x<=n)
    {
        temp=y;
        while(temp<=n)
        {
           a[x][temp]+=data;
           temp+=lowbit(temp);
        }
        x+=lowbit(x);
    }
}
int query(int x,int y)
{
    int sum=0;
    int temp;
    while(x>0)
    {
        temp=y;
        while(temp>0)//二維的就是這樣處理的
        {
            sum+=a[x][temp];
            temp-=lowbit(temp);
        }
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    int test,t,i;
    char c[3];
    int x,y,x1,x2,y1,y2;
    scanf("%d",&test);
    while(test--)
    {
        memset(a,0,sizeof(a));
        scanf("%d%d",&n,&t);
        for(i=0;i<t;i++)
        {
            scanf("%s",c);
            if(c[0]=='C')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);//下面是關鍵
                update(x1,y1,1);
                update(x1,y2+1,1);
                update(x2+1,y1,1);
                update(x2+1,y2+1,1);
            }
            else
            {
                scanf("%d%d",&x,&y);
                printf("%d\n",query(x,y)%2);
            }
        }
        if(test!=0)
        {
            printf("\n");
        }
    }
    return 0;
}

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章