H - Birthday Paradox (生日谬论 思维)

H - Birthday Paradox

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30




生日悖论

 编辑
生日悖论,指如果一个房间里有23个或23个以上的人,那么至少有两个人的生日相同的概率要大于50%。这就意味着在一个典型的标准小学班级(30人)中,存在两人生日相同的可能性更高。对于60或者更多的人,这种概率要大于99%。从引起逻辑矛盾的角度来说生日悖论并不是一种悖论,从这个数学事实与一般直觉相抵触的意义上,它才称得上是一个悖论。大多数人会认为,23人中有2人生日相同的概率应该远远小于50%。计算与此相关的概率被称为生日问题,在这个问题之后的数学理论已被用于设计著名的密码攻击方法:生日攻击

悖论内容

编辑
著名的生日悖论
23个人里有两个生日相同的人的机率有多大呢?
居然有50%
问题是这样的: 如果一个房间里有23个或23个以上的人,那么至少有两个人的生日相同的概率要大于50%。这就意味着在一个典型的标准小学班级(30人)中,存在两人生日相同的可能性更高。对于60或者更多的人,这种概率要大于99%。
不计特殊的年月,如闰二月。
先计算房间里所有人的生日都不相同的概率,那么
第一个人的生日是 365选365
第二个人的生日是 365选364
第三个人的生日是 365选363
:
:
:
第n个人的生日是 365选365-(n-1)
所以所有人生日都不相同的概率是:
那么,n个人中有至少两个人生日相同的概率就是:
所以当n=23的时候,概率为0.507
当n=100的时候,概率为0.999999692751072
对于已经确定的个人,生日不同的概率会发生变化。下面用随机变量计算:
令X[i,j]表示第i个人和第j个人生日不同的概率,则易知任意X[i,j]=364/365
令事件A表示n个人的生日都不相同
P(A)=
 
解P(A)<1/2,由对数可得:n>=23
相比之下,随机变量也同样的简单易懂
,且计算起来要方便得多


code:
#include<iostream>
#include<cstdio>
using namespace std;  
int main() {  
    int t;  
    cin >> t;
    int k=1;  
    while(t--) {  
        int n,ans=1;  
        double p=1;
        cin >> n;     
        for(int j=n-1; j>0; j--) {  
            p=p*(j*1.0)/(n*1.0);  
            if(p<=0.5) {  
                break;  
            }  
            ans++;   
        }  
        printf("Case %d: %d\n",k++,ans);   
    }  
    return 0;  
}  



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章