HDOJ Flying to the Mars

 

Flying to the Mars

http://acm.hdu.edu.cn/showproblem.php?pid=1800

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4208    Accepted Submission(s): 1362


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
 

Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
1 2
水題
#include<iostream>
#include<cstring>
#include<math.h>
using namespace std;
const int MAX=5000;
int hash[MAX],counter[MAX];
int hash_find(char *str){
    int k,t;
    while(*str=='0')
         str++;
    k=atoi(str);
    t=k%MAX;
    if(t<0)
        t+=MAX;
    while(counter[t]&&hash[t]!=k)
         t=(t+1)%MAX;
    hash[t]=k;
    counter[t]++;
    return t;
}
int main(){
    int n,ans,t;
    char str[31];
    while(scanf("%d",&n)==1){
        ans=0;
        memset(counter,0,sizeof(counter));
        while(n--){
              scanf("%s",str);
              t=hash_find(str);
              if(counter[t]>ans)
                   ans=counter[t];         
        }                         
        printf("%d\n",ans);                       
    } 
//system("pause");
return 0;
}

下面的代碼也可,這些字符串的hash轉換函數有點糾結
 參考上一篇中的字符串hash函數很容易理解

//最小掃帚數等於同一水平的最大人數
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN=5000;
int counter[MAXN],hash[MAXN];
int DJBHash(char *str){
    int hash=5381;
    while(*str){
        hash+=(hash<<5)+(*str++);
    }
    return (hash & 0x7fffffff);
}
int hash_fun(char *str){
    int k,t;
    while(*str=='0')
         str++;
    k=DJBHash(str);
    t=k%MAXN;
    while(counter[t] && hash[t]!=k)//處理衝突
          t=(t+1)%MAXN;
    if(counter[t])
          counter[t]++;        
    else{
          hash[t]=k;
          counter[t]=1;
    }
    return t;
}
int main(){
    int n,ans,t;
    char str[31];
    while(scanf("%d",&n)!=EOF){
          ans=0;
          memset(counter,0,sizeof(counter));
          while(n--){
                 scanf("%s",str);
                 t=hash_fun(str);
                 if(counter[t]>ans)
                      ans=counter[t];
          }  
          printf("%d\n",ans);                                                    
    }  
    return 0;
}

下面是另一個hash函數的代碼,其他的hash函數都可以試試看啦,只需把hash函數換成另一個hash函數就可以了,其他的都不變

//最小掃帚數等於同一水平的最大人數
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN=5000;
int counter[MAXN],hash[MAXN];
int JSHash(char *str){
    int hash=1315423911;
    while(*str){
         hash+=((hash<<5)+(*str++)+(hash>>2));
    }
    return (hash & 0x7fffffff);
}
int hash_fun(char *str){
    int k,t;
    while(*str=='0')
         str++;
    k=JSHash(str);
    t=k%MAXN;
    while(counter[t] && hash[t]!=k)//處理衝突
          t=(t+1)%MAXN;
    if(counter[t])
          counter[t]++;        
    else{
          hash[t]=k;
          counter[t]=1;
    }
    return t;
}
int main(){
    int n,ans,t;
    char str[31];
    while(scanf("%d",&n)!=EOF){
          ans=0;
          memset(counter,0,sizeof(counter));
          while(n--){
                 scanf("%s",str);
                 t=hash_fun(str);
                 if(counter[t]>ans)
                      ans=counter[t];
          }  
          printf("%d\n",ans);                                                    
    }  
    return 0;
}

下面這個BKDRHash函數容易記住

//最小掃帚數等於同一水平的最大人數
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN=5000;
int counter[MAXN],hash[MAXN];
int BKDRHash(char *str){
    int seek=131;
    int hash=0;
    while(*str){
        hash=hash*seek+(*str++);
    }
    return (hash & 0x7fffffff);
}
int hash_fun(char *str){
    int k,t;
    while(*str=='0')
         str++;
    k=BKDRHash(str);
    t=k%MAXN;
    while(counter[t] && hash[t]!=k)//處理衝突
          t=(t+1)%MAXN;
    if(counter[t])
          counter[t]++;        
    else{
          hash[t]=k;
          counter[t]=1;
    }
    return t;
}
int main(){
    int n,ans,t;
    char str[31];
    while(scanf("%d",&n)!=EOF){
          ans=0;
          memset(counter,0,sizeof(counter));
          while(n--){
                 scanf("%s",str);
                 t=hash_fun(str);
                 if(counter[t]>ans)
                      ans=counter[t];
          }  
          printf("%d\n",ans);                                                    
    }  
    return 0;
}

 

 

 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章