LightOJ - 1104 Birthday Paradox (期望DP)

Birthday Paradox

 

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

題目鏈接:https://vjudge.net/problem/LightOJ-1104

題目大意:這個星球上一年有n天,要求晚會上至少有兩個人在同一天生日的概率要大於等於0.5,問至少要邀請多少人來參加晚會

思路:沒有同一天生日的人的概率是P=(n-1)/n * (n-2)/n * (n-3)/n......(n-i)/n ,要使至少兩人同一天生日的概率大於等於0.5,那麼就是要使沒有人同一天生日的概率小於等於0.5;

代碼:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        double x=1;
        int i=1;
        while(i<n)
        {
            if(i==n) break;
            x*=1.0*(n-i)/n;
            if(x<=0.5) break;
            i++;
        }
        printf("Case %d: %d\n",T++,i);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章