LightOJ - 1027 A Dangerous Maze (期望)

A Dangerous Maze

 

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

 

題目鏈接:https://vjudge.net/problem/LightOJ-1027

題目大意:迷宮中有n個門,如果ai爲正,說明通過這面門ai分鐘後能走出迷宮,如果ai爲負,則說明|ai|分鐘後會回到原處,問走出迷宮要花的時間的期望

思路:現在設走出迷宮的期望爲x,那麼可以列出

x= 1/n * ( sum( ai ) (ai爲正) )  + 1/n * (sum( |ai| +x ) (ai爲負) ) 

所以化簡公式可得:x = sum / ( n - cnt )  (sum爲所有|ai| 的和,cnt是ai爲負的數量)

代碼:

#include<bits/stdc++.h>
using namespace std;
const int N=105;
int a[N];
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,x,cnt=0,sum=0;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            if(x<0) cnt++;
            sum+=abs(x);
        }
        if(cnt==n) printf("Case %d: inf\n",T++);
        else
        {
            int p=__gcd(sum,n-cnt);
            printf("Case %d: %d/%d\n",T++,sum/p,(n-cnt)/p);
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章