LightOJ - 1027 A Dangerous Maze (期望)

A Dangerous Maze

 

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

 

题目链接:https://vjudge.net/problem/LightOJ-1027

题目大意:迷宫中有n个门,如果ai为正,说明通过这面门ai分钟后能走出迷宫,如果ai为负,则说明|ai|分钟后会回到原处,问走出迷宫要花的时间的期望

思路:现在设走出迷宫的期望为x,那么可以列出

x= 1/n * ( sum( ai ) (ai为正) )  + 1/n * (sum( |ai| +x ) (ai为负) ) 

所以化简公式可得:x = sum / ( n - cnt )  (sum为所有|ai| 的和,cnt是ai为负的数量)

代码:

#include<bits/stdc++.h>
using namespace std;
const int N=105;
int a[N];
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,x,cnt=0,sum=0;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            if(x<0) cnt++;
            sum+=abs(x);
        }
        if(cnt==n) printf("Case %d: inf\n",T++);
        else
        {
            int p=__gcd(sum,n-cnt);
            printf("Case %d: %d/%d\n",T++,sum/p,(n-cnt)/p);
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章