查並集訓練~How Many Tables~解題報告

How Many Tables

題目描述:

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input:

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output:

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input:

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output:

2
4

思路:

簡單的尋找根節點,併合並根節點,集合成一個集合就行了,簡單的並查集模板題。

代碼:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<set>
using namespace std;
int f[2000];
int p[2000];
int LemonFind(int u)//找出根節點 
{
	if(f[u]!=u)
	{
		f[u]=LemonFind(f[u]);
	}
	return f[u];
}
void LemonGetroot(int u,int v)//合併集合 
{
	int x1=LemonFind(u);//找出根節點 
	int x2=LemonFind(v);//找出根節點 
	if(x1!=x2)//如果根節點不相等,就改變父節點的去向 
	{
		f[x2]=x1;
	}
}
int main()
{
	int t;
	int n,m;
	int u,v;
	scanf("%d",&t);
	while(t--)
	{
		set<int>q;
		int cnt=0;
		scanf("%d %d",&n,&m);
		for(int i=1;i<=n;i++)//初始化一下根節點 
		{
			f[i]=i;
		}
		for(int i=1;i<=m;i++)
		{
			scanf("%d %d",&u,&v);
			LemonGetroot(u,v);//合併集點 
		}
		for(int i=1;i<=n;i++)
		{
			q.insert(LemonFind(i));//用set來判斷重合元素 
		}
		printf("%d\n",q.size());
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章