uva12627 Erratic Expansion (遞歸)

Erratic Expansion


Piotr found a magical box in heaven. Its magic power is that if you place any red balloon inside it then, after one hour, it will multiply to form 3 red and 1 blue colored balloons. Then in the next hour, each of the red balloons will multiply in the same fashion, but the blue one will multiply to form 4 blue balloons. This trend will continue indefinitely.
The arrangements of the balloons after the 0-th, 1-st, 2-nd and 3-rd hour are depicted in the following diagram.

如圖

As you can see, a red balloon in the cell (i, j) (that is i-th row and j-th column) will multiply to produce 3 red balloons in the cells (i ∗ 2 − 1, j ∗ 2 − 1), (i ∗ 2 − 1, j ∗ 2), (i ∗ 2, j ∗ 2 − 1) and a blue balloon in the cell (i ∗ 2, j ∗ 2). Whereas, a blue balloon in the cell (i, j) will multiply to produce 4 blue balloons in the cells (i ∗ 2 − 1, j ∗ 2 − 1), (i ∗ 2 − 1, j ∗ 2), (i ∗ 2, j ∗ 2 − 1) and (i ∗ 2, j ∗ 2). The grid size doubles (in both the direction) after every hour in order to accommodate the extra balloons.
In this problem, Piotr is only interested in the count of the red balloons; more specifically, he would like to know the total number of red balloons in all the rows from A to B after K-th hour.
Input
The first line of input is an integer T (T < 1000) that indicates the number of test cases. Each case contains 3 integers K, A and B. The meanings of these variables are mentioned above. K will be in the range [0, 30] and 1 ≤ A ≤ B ≤ 2 K.
Output
For each case, output the case number followed by the total number of red balloons in rows [A, B] after K-th hour.
Sample Input
3
0 1 1
3 1 8
3 3 7
Sample Output
Case 1: 1
Case 2: 27
Case 3: 14


這題只要求我們看紅色氣球的數量,我們把每行的紅色氣球數量豎着寫下來,很容易就可以發現這張圖形的變化規律,即每次圖形上方複製出一個圖形,上面每行的數量是下面每行的兩倍,原來的圖形的數量不變。這裏需要利用遞歸的思想來寫。


#include <cstdio>
#include <iostream>
using namespace std;
int k;
int Pow(int a,int b)
{
    int base =a;
    int ans = 1;
    while(b!=0)
    {
        if(b&1)
            ans*=base;
        b>>=1;
        base*=base;
    }
    return ans;
}
long long c(int k)
{
    if(k==0)return 1;
    else
        return 3*c(k-1);
}
long long f(int k,int i)
{
    if(i<=0) return 0;
    if(k==0) return 1;
    if(i>=Pow(2,k-1)) return (f(k-1,i-Pow(2,k-1))+2*c(k-1));
    else return 2*f(k-1,i);
}
int main()
{

    int t;
    cin>>t;
    int k,a,b;
    int kase=0;
    while(t--)
    {
        scanf("%d %d %d",&k,&a,&b);
        long long ans =f(k,b)-f(k,a-1);
        printf("Case %d: %lld\n",++kase,ans);
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章