acm pku 1144 ID Codes的算法分析

ID Codes

Description

It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:

      abaabc

      abaacb

      ababac
 


These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters.

Input

Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

Output

Output will consist of one line for each code read containing the successor code or the words 'No Successor'.

Sample Input

abaacb
cbbaa
#

Sample Output

ababac
No Successor

Source

New Zealand 1991 Division I,UVA 146

 

       分析:對某個包含某些特定數字(0~9)的數,求包含這些數字且比已知數大的最小數。這道題目只不過是把具體的數字(0~9)換成了小寫字母(a~z),其具體算法如下:

1,  從字符串末尾開始,對某個字符str[i],找出它前面離它最近的,且比它小的字符str[j](顯然j<i)。若不存在這樣的字符,則i--,繼續尋找滿足條件的j, i== 0,則輸出”No Successor” 否則:

2,  交換str[i]str[j];對str[i+1]以及其後的字母按從小到大的次序進行排列,並將排列的結果接到str[i]之後,則新的str就是所有的結果。

 

具體實現:

#include "iostream"

#include "string.h"

#include "stdlib.h"

 

using namespace std;

//Compiler error1

const int N = 55;

char str[N];

 

int cmp(const void *a, const void *b)

{

       return *(char *)a - *(char *)b;

}

 

void Successor(char *str)

{

       int i, j, len = strlen(str);

       bool flag = false;

       char chr, *ctmp;

       ctmp = new char[N];

       ctmp[0] = '/0';

 

       for(i = len-1; i > 0; i--)

       {

              for(j = i-1; j > -1; j--)

              {

                     if(str[i] > str[j])

                     {

                            chr = str[i];

                            str[i] = str[j];

                            str[j] = chr;

                            flag = true;

                            break;

                     }

              }

              if(flag) break;

       }

       if(i == 0) cout << "No Successor" <<endl;

       else

       {

              strcpy(ctmp, &str[j+1]);

              str[j+1] = '/0';

              qsort(ctmp, strlen(ctmp), sizeof(char), cmp);

              strcat(str, ctmp);

              cout << str <<endl;

       }

}

 

int main(void)

{

       cin >> str;

       while(strcmp(str, "#") != 0)

       {

              Successor(str);

              cin >> str;

       }

       return 0;

}

 

執行結果:

 

Problem: 1146

 

User: uestcshe

Memory: 680K

 

Time: 0MS

Language: G++

 

Result: Accepted

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章