acm pku 1125 Stockbroker Grapevine的Dijkstra算法實現

Stockbroker Grapevine

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001

 

       這實則是一道求某一網絡中,從某點到達網絡中其它點的距離,題目要求找出具有最短具體的點。Dijkstra算法是解決從網絡中的點到某點的最短距離的有效算法,若網絡中的點個數爲N Dijkstra算法的時間複雜度是O(N*N*N)本題也可以運用Dijkstra算法來求解,通過遍歷求出從某stockbroker開始將”rumours”傳到每個人所用的時間,並比較從不同stockbroker傳出消息到所有人的時間,並輸出最小傳播時間所對應的起始stockbroker和時間。如果無法傳遍所有的stockbroker,則輸出”disjoint” 算法的總體時間複雜度O(N^3)

具體實現:

#include "iostream"

using namespace std;

 

const int N = 101;

const int MAX = 1000000;

int itg[N][N];

int cost[N];

 

 

void Dijkstra(int begin, int n)

{

       int i, j, min, ip;

       bool bflag[N];

 

       for(i = 1; i <= n; i++)

       {

              if(itg[begin][i] != 0) cost[i] = itg[begin][i];

              else cost[i] = MAX;

              bflag[i] = false;

       }

       cost[begin] = 0;

       bflag[begin]= true;

 

       for(i = 1; i <= n; i++)

       {    

              min = MAX;

              ip = i;

              for(j = 1; j <=n; j++)

              {

                     if(!bflag[j] && cost[j] < min)

                     {

                            ip = j;

                            min = cost[j];

                     }

              }

              bflag[ip] = true;

              for(j = 1; j <= n; j++)

              {

                     if(!bflag[j] && cost[ip]+itg[ip][j] < cost[j]) cost[j] = cost[ip] + itg[ip][j];

              }

       }

}

 

int main(void)

{

       int row, col;

       int i, j, tmpcol, tmpcost, mincost;

       int flag = 1;

 

       cin >> row;

       while(row != 0)

       {

              for(i = 1; i <= row; i++)

              {

                     cin >> col;

                     for(j = 1; j <= row; j++) itg[i][j] = MAX;

                     for(j = 0; j < col; j++)

                     {

                            cin >> tmpcol;

                            cin >> itg[i][tmpcol];

                     }

              }

 

              mincost = MAX;

              for(i = 1; i <= row; i ++)

              {

                     Dijkstra(i, row);

                     tmpcost = 0;

                     for(j = 1; j <= row; j++)

                     {

                            if(tmpcost < cost[j]) tmpcost = cost[j];

                     }

                     if(mincost > tmpcost)

                     {

                            flag = i;

                            mincost = tmpcost;

                     }

              }

 

              if(mincost == MAX) cout << "disjoint" << endl;

              else cout << flag << " " << mincost <<endl;

 

              cin >> row;

       }

 

       return 0;

}

執行結果:

Problem: 1125

 

User: uestcshe

Memory: 208K

 

Time: 0MS

Language: C++

 

Result: Accepted

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章