Marriage Ceremonies--Light OJ 1011

Marriage Ceremonies

題目位置:

Light OJ 1011

題目:

You work in a company which organizes marriages. Marriages are not that easy to be made, so, the job is quite hard for you.

The job gets more difficult when people come here and give their bio-data with their preference about opposite gender. Some give priorities to family background, some give priorities to education, etc.

Now your company is in a danger and you want to save your company from this financial crisis by arranging as much marriages as possible. So, you collect N bio-data of men and N bio-data of women. After analyzing quite a lot you calculated the priority index of each pair of men and women.

Finally you want to arrange N marriage ceremonies, such that the total priority index is maximized. Remember that each man should be paired with a woman and only monogamous families should be formed.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains an integer N (1 ≤ n ≤ 16), denoting the number of men or women. Each of the next N lines will contain N integers each. The jth integer in the ith line denotes the priority index between the ith man and jth woman. All the integers will be positive and not greater than 10000.

Output
For each case, print the case number and the maximum possible priority index after all the marriages have been arranged.

Sample Input
2
2
1 5
2 1
3
1 2 3
6 5 4
8 1 2
Sample Output
Case 1: 7
Case 2: 16

做法

做法1 做法2 做法3
暴力 狀壓DP 剪枝的DP
玄學錯誤! 枚舉狀態 加上了二進制的函數
WA,TLE,RE TLE AC

就是想到了到了第i號男人的選定的時候,就是會有i-1位女嘉賓被選了!
所以在枚舉狀態的時候就是加上一個判斷二進制 1 的個數的函數!
別的和普通狀壓DP是一樣的!

數二進制有幾個 1 :__builtin_popcount() 

代碼

#include <bits/stdc++.h>
using namespace std;
#define N 18
int T,n,k;
int dp[N][1<<N],a[N][N];
int main()
{
    scanf("%d",&T);
    for(int loc=1; loc<=T; loc++)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&a[i][j]);
        int final=1<<n;
        for(int i=0;i<n;i++) dp[0][1<<i]=a[0][i];

        for(int i=1; i<n; i++)
            for(int used=0; used<final; used++)
                if(__builtin_popcount(used)==i)
                    for(int j=0; j<n; j++)
                    if(!(used & (1<<j)))
                    {
     dp[i][used|(1<<j)]=max(dp[i-1][used]+a[i][j],dp[i][used|(1<<j)]);
                    }
        printf("Case %d: %d\n",loc,dp[n-1][final-1]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章