挑戰程序設計競賽 POJ 3253 貪心+霍夫曼思想+優先隊列


Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 43729   Accepted: 14256

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source



注意

1.優先隊列取數的時候是從大開始取,用greater改成從小開始取值,頭文件functional

priority_queue<int, vector<int>, greater<int> > pque;

2.這類籬笆分割的問題可以利用哈夫曼樹,每次都取最小的兩個,其實就是求最小的WPL,



/*
* poj 3253
* author  : mazciwong
* creat on: 2016-1-15
*/

/*
貪心,類似於用二叉樹構造霍夫曼樹
每次取最小的兩個加起來再加到原來那裏,
利用優先隊列可以把找最小的O(n) 轉換成O(log n)
*/


#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <functional> //greater
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 20000 + 5;
int l[maxn];
int n;

void solve()
{
	ll ans = 0;

	//優先隊列是從大開始取的,這樣寫可以從小開始取出來,利用堆數據結構
	priority_queue<int, vector<int>, greater<int> > pque;
	for (int i = 0; i < n; i++)
		pque.push(l[i]);

	//一直循環到只有一塊 → 就是最開始的那塊木板了
	while (pque.size() > 1)
	{
		int l1 = pque.top();
		pque.pop();
		int l2 = pque.top();
		pque.pop();

		ans += l1 + l2;
		pque.push(l1 + l2);
	}
	printf("%lld\n", ans);
}
int main()
{
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d", &l[i]);
	solve();
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章