湫湫系列故事——減肥記I HDU - 4508

傳送門

對於喫貨來說,過年最幸福的事就是吃了,沒有之一!
  但是對於女生來說,卡路里(熱量)是天敵啊!
  資深美女湫湫深諳“胖來如山倒,胖去如抽絲”的道理,所以她希望你能幫忙制定一個食譜,能使她喫得開心的同時,不會製造太多的天敵。

當然,爲了方便你製作食譜,湫湫給了你每日食物清單,上面描述了當天她想喫的每種食物能帶給她的幸福程度,以及會增加的卡路里量。

Input

輸入包含多組測試用例。
  每組數據以一個整數n開始,表示每天的食物清單有n種食物。
  接下來n行,每行兩個整數a和b,其中a表示這種食物可以帶給湫湫的幸福值(數值越大,越幸福),b表示湫湫喫這種食物會吸收的卡路里量。
  最後是一個整數m,表示湫湫一天吸收的卡路里不能超過m。

[Technical Specification]
  1. 1 <= n <= 100
  2. 0 <= a,b <= 100000
  3. 1 <= m <= 100000

Output

對每份清單,輸出一個整數,即滿足卡路里吸收量的同時,湫湫可獲得的最大幸福值。

Sample Input

3
3 3
7 7
9 9
10
5
1 1
5 3
10 3
6 8
7 5
6

Sample Output

10
20

代碼:

#include<iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <map>
#include <functional>
#include <ctime>
#include <iomanip>
#include <sstream>
#include <algorithm>
#define ll long long
#define PI acos(-1)
#define mes(x,y) memset(x,y,sizeof(x))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);cout.tie(0)
using namespace std;
const ll INF = 1e9 + 10;
ll n, m, k, i, j, x, y;
string s;
ll a[200000];
struct node {
	ll harm, price;
}b[200000];
bool cmp(node n1, node n2) {
	return n1.harm > n2.harm;
}
int main() {
	FAST_IO;
	while (cin >> n >> m) {
		priority_queue<ll, vector<ll>, greater<ll>>que;
		for (i = 0; i < n; i++)cin >>a[i];
		for (i = 0; i < m; i++)cin >> b[i].harm;
		for (i = 0; i < m; i++)cin >> b[i].price;
		sort(a, a + n);
		sort(b, b + m, cmp);
		bool flag = true;
		ll sum = 0;
		for (i = n - 1, j = 0; i >= 0; i--) {
			while (j<m && b[j].harm>=a[i])que.push(b[j++].price);
			if (que.empty()) {
				flag = false;
				break;
			}
			else {
			//	cout << a[i] << " " << que.top() << endl;
				sum += que.top();
				que.pop();
			}
		}
		if (flag)cout << sum << endl;
		else cout << "No" << endl;
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章