一、B - Candy Sharing Game

B - Candy Sharing Game

HDU - 1034

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8


        
  

Hint

The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

每次判斷每個學生的糖果數量是否相同,如果不同的話,則進行操作更新每個學生新一輪的糖果數量

新一輪每一個學生的糖果數量爲當前數量的一半加上前一個學生糖果數量的一半,如果數量爲奇數,加一。

#include <stdio.h>
#include <stdlib.h>
#define max 1000

int judge(int s[],int n);

int main()
{
    int student[max];
    int num;
    while(scanf("%d",&num))
    {
        if(num == 0) break;
        int i,counter = 0;
        for(i = 0;i < num;i++)
        {
            scanf("%d",&student[i]);
        }
        while(!judge(student,num))
        {
            int temp  = student[num-1];
            for(i = 1;i < num; i++)
            {
                student[i] = student[i]/2 + student[i-1]/2;
            }
            student[0]=student[0]/2 + temp/2;

            for(i = 0;i < num; i++)
            {
                if(student[i]%2) student[i]++;
            }
            counter++;
        }
    printf("%d %d",counter,student[0]);
    }
    return 0;
}

int judge(int s[],int n)
{
    int i;
    for(i = 1;i < n;i++)
    {
        if(s[i] != s[0]) return 0;
    }
    return 1;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章