Monkey and Banana

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

題目大意:
給你n種長方體(每種長方形數目不限),並給出它的三邊長,讓你求出用這些長方體堆成塔型的最大高度。(要求:塔下面的長方體的長和寬必須大於上面的長方體)

思路:

  1. 每種長方體都都有三种放法:分別以x,y,z爲高。因此我們要先處理一下輸入的數據。
  2. 處理好了輸入之後,就開始找狀態了,這道題其實就是一個最長上升子序列問題。我們可以用f[i] //前i種處理完的長方體所擺成的最大高度表示狀態。
  3. 因爲有兩個參數(長和寬)因此我們要先固定一個參數,按x從小到大進行排序。這樣這道題就轉化爲了一道最長上升子序列的問題。
  4. 狀態方程爲:當a[i].x<a[j].x&&a[i].y<a[j].y時,f[i]=max(f[i],f[j]+a[i].h)

最長上升子序列

ac代碼:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <queue>
#include <algorithm>
#include <iomanip>
#define LL long long
const int N=1e3+5,mod=1e9+7;
using namespace std;
struct Node{
	int x,y,h;     //x長,y寬,h高
	bool operator< (Node const &a) const  //排序準則
	{                                     //按x從小到大排序
		if(x!=a.x) return x<a.x;
		return y<a.y; 
	}
}a[N]; 
int f[N];
int main()
{
	int n,k=0;
	while(cin>>n,n)     //輸入多組數據
	{
		memset(f,0,sizeof f);   //清空f數組
		int m=0;
		while(n--)      //對輸入數據進行處理
		{
			int x,y,z;
			cin>>x>>y>>z;
			m++;
			a[m].x=max(x,y),a[m].y=min(x,y),a[m].h=z;
			m++;
			a[m].x=max(y,z),a[m].y=min(y,z),a[m].h=x;
			m++;
			a[m].x=max(x,z),a[m].y=min(x,z),a[m].h=y;
		}
		sort(a+1,a+1+m);
		
		int ans=0;
		for(int i=m;i>=1;i--)
		{
			f[i]=a[i].h;     //初始化
			for(int j=i+1;j<=m;j++)
			if(a[i].x<a[j].x&&a[i].y<a[j].y)
			f[i]=max(f[i],f[j]+a[i].h);
			ans=max(ans,f[i]);   //ans記錄f[i]中的最大值
		}
		cout<<"Case "<<++k<<": maximum height = "<<ans<<endl;
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章