HDU--1213--How Many Tables【並查集】

Description

Today isIgnatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatiuswants to know how many tables he needs at least. You have to notice that notall the friends know each other, and all the friends do not want to stay withstrangers. 

One important rule for this problem is that if I tell you A knows B, and Bknows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C canstay in one table, and D, E have to stay in the other one. So Ignatius needs 2tables at least. 

 

Input

The input startswith an integer T(1<=T<=25) which indicate the number of test cases. ThenT test cases follow. Each test case starts with two integers N andM(1<=N,M<=1000). N indicates the number of friends, the friends aremarked from 1 to N. Then M lines follow. Each line consists of two integers Aand B(A!=B), that means friend A and friend B know each other. There will be ablank line between two cases. 

 

Output

For each testcase, just output how many tables Ignatius needs at least. Do NOT print anyblanks. 

 

Sample Input

 2

5 3

1 2

2 3

4 5

 

5 1

2 5

 

Sample Output

 2

4

 

 

解題思路:找有幾個父節點

#include<bits/stdc++.h>
#include<set>
using namespace std;
int father[10010];
int findf(int x)
{
	int a=x;
	while(x!=father[x])
	{
		x=father[x];
	}
	//路徑壓縮
	 while(a!=father[a])
	 {
	 	int z=a;
	 	a=father[a];
	 	father[z]=x;
	 }
	return x;
}
void Union(int a,int b)
{
	int x,y;
	x=findf(a);
	y=findf(b);
	if(x!=y)
	{
		father[x]=y;		
	}
}
int main()
{
	int t,n,m;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		for(int i=1;i<=n;i++)
		father[i]=i;
		for(int i=0;i<m;i++)
		{
			int a,b;
			cin>>a>>b;
			if(findf(a)!=findf(b))
			{
				Union(a,b);
				n--;
			}
		}
		cout<<n<<endl;
	}
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章