完全二叉搜索树Complete Binary Search Tree

问题描述

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input

10
1 2 3 4 5 6 7 8 9 0

Sample Output

6 3 8 1 5 7 9 0 2 4

思路分析

先将输入排个序,然后最小的结点放在树中的最左下的结点,次小的放在上个结点的根结点,再次小的放在根结点的右子树上,递归放置,最后层序输出即可。

C语言代码

#include <stdio.h>
#include <stdlib.h>

int b[2048];
int pos = 0;

void sort(int *arr, int num)
{
    int i, j;
    int temp;

    for(i=0;i<num;i++) {
        for(j=i;j<num;j++) {
            if(arr[i]>arr[j]) {
                temp = arr[j];
                arr[j] = arr[i];
                arr[i] = temp;
            }
        }
    }
}

void mid_tree(int root, int N, int a[])
{
    if(root<=N) {
        mid_tree(2*root, N, a);
        b[root] =  a[pos++];
        mid_tree(2*root+1, N, a);
    }
}

int main()
{
    int N, i;
    int data[2048];
    scanf("%d\n", &N);
    for(i=0;i<N;i++) {
        scanf("%d", &data[i]);        
    }
    sort(data, N);
    mid_tree(1, N, data);
    for(i=1;i<=N;i++) {
        if(i==1) {
            printf("%d", b[i]);
        } else {
            printf(" %d", b[i]);
        }
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章