ZOJ - 3776 水題

Pokemon Master

題目:

Time Limit: 2000 msMemory Limit: 65536 KB

Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each's team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 6), which describes that Calem has N pokemons and Serena has M pokemons.

The second line contains N integers indicating the weight of Calem's pokemons. The third line contains M integers indicating the weight of Serena's pokemons. All pokemons' weight are in the range of [1, 2094] pounds.

Output

For each test case, output "Calem" if Calem's team will win the battle, or "Serena" if Serena's team will win. If the two team have the same total weight, output "Draw" instead.

Sample Input

1
6 6
13 220 199 188 269 1014
101 176 130 220 881 396

Sample Output

Serena

題解:兩個數組分別求和比大小

代碼:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a[10], b[10];

int main()
{
	int t, m , n, i, j, k,suma=0, sumb = 0;
	scanf("%d",&t);
	while(t--){
		suma = sumb=0;
		scanf("%d %d",&n,&m);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			suma+=a[i];
		}
		for(i=0;i<m;i++)
		{
			scanf("%d",&b[i]);
			sumb+=b[i];
		}
		if(suma>sumb){
			printf("Calem\n");
		} else if(suma<sumb) {
			printf("Serena\n");
		} else{
			printf("Draw\n");
		}
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章