poj Period 1961

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 16988   Accepted: 8172

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

這幾天一直在做最大流問題的題目,發現有點做不動,所以就一直沒有更新博客。

也是這幾個星期要考試的緣故沒有太多的時間去學更多的東西, 以後一定補上。

這個題就是一個KMP的題目

題意就是讓你找字符串的週期

如例2

前兩個字母有兩個週期,單週期爲a

前六個字母也有兩個週期,單週期爲aab

前九個字母有三個週期,單週期爲aab

....

代碼:

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

char ch[1000005];
int next[1000005];

void Get(char *s, int next[])
{
    int i, j;
    i = 0, j = -1;
    next[0] = -1;
    while ( s[i] )
    {
        if ( j == -1||s[i] == s[j] )
        {
            i++, j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int main()
{
    int n, i;
    int Num = 1;
    while ( ~scanf ( "%d", &n )&& n != 0 )
    {
        scanf ( "%s", ch );
        Get( ch, next );
        printf ( "Test case #%d\n", Num++ );
        for ( i = 1;i <= n; i++ )
        {
            if ( i%(i-next[i]) == 0&&i != i-next[i] )
                printf ( "%d %d\n", i, i/(i-next[i]) );
        }
        printf ( "\n" );
    }
    return 0;
}

代碼菜鳥,如有錯誤,請多包涵!!!

如有幫助記得支持我一下,謝謝!!!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章