10041 - Vito's Family

 


Problem C: Vito's family

Background

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

Problem

Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

Input

The input consists of several test cases. The first line contains the number of test cases.

For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$ where they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.

Output

For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij= |si-sj|.

Sample Input

2
2 2 4 
3 2 4 6

Sample Output

2
4



Miguel Revilla
2000-11-19
類似10057
#include <stdio.h>
#include <math.h>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{ 
 int s,a[501],i,n,t,T;
 scanf("%d",&T);
 while (T--)
 {
 scanf("%d",&n);
 for (i=1;i<=n;i++)
 scanf("%d",&a[i]);
 s=0; t=(n+1)/2;
 sort(a+1,a+n+1);
 for (i=1;i<=n;i++)
 s=s+abs(a[i]-a[t]);
 printf("%d\n",s);
 }
 return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章