ZOJ2850 Beautiful Meadow java

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2850

                                  Beautiful Meadow

                                                       

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No

题意:

Tom有一片花园,初始所有方块的覆盖草,你需要除草使它成为最美花园,有2个条件。

1:不能所有的方块都覆盖草。

2:不能两个相邻的方块覆盖草。

数字0意味着草地是修剪过的,数字1意味着是草覆盖的。

思路:

首先判断所有方块是不是覆盖草,如果有修建的,就判断是否相邻两个是修建过的,如果是则返回NO,否则YES。

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int n=sc.nextInt();
			int m=sc.nextInt();
			if(n==0&&m==0){
				break;
			}
			boolean flag=false;
			int a[][]=new int[n][m];
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){
					a[i][j]=sc.nextInt();
				}
			}
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){	//判断是否修剪过,修建过就是true
					if(a[i][j]==0){
						flag=true;
						break;
					}
				}
				if(flag==true)break;
			}
			for(int i=0;i<m-1&&flag==true;i++){	//判断有没有相邻的修建的方块
				if(a[0][i]==0&&a[0][i+1]==0){
					flag=false;
				}
			}
			for(int i=0;i<n-1&&flag==true;i++){ //判断有没有相邻的修建的方块
				if(a[i][0]==0&&a[i+1][0]==0){
					flag=false;
				}
			}
			for(int i=1;i<n&&flag==true;i++){
				for(int j=1;j<m;j++){
					if((a[i][j]==0&&a[i-1][j]==0)||(a[i][j]==0&&a[i][j-1]==0)){ //判断有没有相邻的修建的方块
						flag=false;
						break;
					}
				}
			}
			if(flag==true){
				System.out.println("Yes");
			}
			else{
				System.out.println("No");
			}
		}
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章