HDU 4283 You Are the One(区间DP)

原题地址

You Are the One

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3502 Accepted Submission(s): 1614


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input
  The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

Output
  For each test case, output the least summary of unhappiness .

Sample Input
2    5 1 2 3 4 5 5 5 4 3 2 2

Sample Output
Case #1: 20 Case #2: 24

一群屌丝去参加非诚勿扰,但是他们要排队上场,他们每个人都有一个愤怒值D,如果他是第k个上场,那么他的不开心值就会是(k-1)*D。即是说,如果他前面多一个人先上场,那就多D不开心值(不怕屌丝去相亲,就怕屌丝玻璃心……)。

但是这里有一个小黑屋,其实就是个栈。屌丝按顺序进入栈,经过调整顺序后出来,请问可以调整后得到的所有人不开心值得和最小的是多少?(人善被人欺呗)

思路:

一开始,屌丝们的顺序就被定好了,只能经过栈调整。

如果只看第i个人的话,经过栈的调整后,i可以是第一个出来,或者最后一个出来,或者在之间出来。现在假设i是提前了k个人出来的(k可以为负数,即是推迟k个人后出来),那么i之前(之后)的k个人就会因为 i 的位置调整而多等待(少等待)一个人。所以他们的不开心值都会增加(减少)自己对应的D。而 i 会减少(增加)自身的D*k。所以状态转移方程也出来了:

dp[i][j]=min(dp[i][j],dp[i+1,i+k-1]+dp[i+k,j]+(k-1)*a[i]+(sum[j]-sum[i+k-1])*k); 

dp[ i ][ j ]为区间 [ i , j ] 的屌丝经过栈调整后的最小不开心值(忽略 i 前面的人)。

a[ i ]为第i个人的愤怒值。

sum[ i ]第0~i 个人的愤怒值的和。


下面贴代码:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>

using namespace std;

int sum[111];
int unh[111];
int dp[111][111];

int n;
int deal(int a,int b)
{
    if(a>=b)
    {
        return 0;
    }
    if(dp[a][b]!=-1)
    {
        return dp[a][b];
    }
    dp[a][b]=0x3f3f3f3f;
    //printf("!!!%d %d %d\n",a,b,dp[a][b]);
    for(int k=0;k<b-a+1;k++)
        dp[a][b]=min(dp[a][b],deal(a+1,a+k)+deal(a+k+1,b)+k*unh[a]+(k+1)*(sum[b]-sum[a+k]));

    //printf("!%d %d %d\n",a,b,dp[a][b]);
    return dp[a][b];
}
int main()
{
    int t,cake=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,-1,sizeof(dp));
        scanf("%d",&n);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&unh[i]);
            sum[i]=sum[i-1]+unh[i];
        }
        printf("Case #%d: %d\n",cake++,deal(1,n));
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章