POJ 1330 Nearest Common Ancestors(LCA 離線算法)

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3


題目大意:同上一篇,求最近公共祖先。

Tarjan 離線算法,將詢問全都存下來。對於一棵樹,先進行 DFS,當一個點的子節點全部訪問過以後,找與它有關係

(即要詢問最近公共祖先的點對)的點,若未訪問過,則不進行操作;若訪問過,並查集找到它的祖先即爲二者的最近公共祖先。

代碼:

#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
const int maxn = 1e4 + 5;
int n;
int in[maxn];
int p[maxn];
bool vis[maxn];
map<int,int> sea;
vector<int> v[maxn];
// 並查集
int Find(int x)
{
    return x == p[x] ? x : p[x] = Find(p[x]);
}
// 初始化
void Init()
{
    for(int i = 1;i <= n; ++i)
    {
        v[i].clear();
        in[i] = 0;
        vis[i] = false;
        p[i] = i;
    }
    sea.clear();
}
// Trajan離線求 LCA
bool Tarjan(int x)
{
    int len = v[x].size();
    for(int i = 0;i < len; ++i)
    {
        int u = v[x][i];
        if(!vis[u])
        {
            vis[u] = true;
            if(Tarjan(u)) return true;
            p[u] = x;
        }
    }
    if(sea[x] && vis[sea[x]])
    {
        printf("%d\n",Find(sea[x]));
        return true;
    }
    return false;
}
int main()
{
    int t,root;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        Init();
        int x,y;
        for(int i = 1;i < n; ++i)
        {
            scanf("%d %d",&x,&y);
            v[x].push_back(y);
            in[y]++;
        }
        int a,b;
        scanf("%d %d",&a,&b);
        sea[a] = b,sea[b] = a;
        for(int i = 1;i <= n; ++i)
        {
            if(!in[i])
            {
                root = i;
                break;
            }
        }
        vis[root] = true;
        Tarjan(root);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章