HDU 1236 排名 Java實現

排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20727    Accepted Submission(s): 7689


Problem Description
今天的上機考試雖然有實時的Ranklist,但上面的排名只是根據完成的題數排序,沒有考慮 
每題的分值,所以並不是最後的排名。給定錄取分數線,請你寫程序找出最後通過分數線的 
考生,並將他們的成績按降序打印。 
 

Input
測試輸入包含若干場考試的信息。每場考試信息的第1行給出考生人數N ( 0 < N 
< 1000 )、考題數M ( 0 < M < = 10 )、分數線(正整數)G;第2行排序給出第1題至第M題的正整數分值;以下N行,每行給出一 
名考生的准考證號(長度不超過20的字符串)、該生解決的題目總數m、以及這m道題的題號 
(題目號由1到M)。 
當讀入的考生人數爲0時,輸入結束,該場考試不予處理。 
 

Output
對每場考試,首先在第1行輸出不低於分數線的考生人數n,隨後n行按分數從高 
到低輸出上線考生的考號與分數,其間用1空格分隔。若有多名考生分數相同,則按他們考 
號的升序輸出。 
 

Sample Input
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
 

Sample Output
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.
 

Source

import java.awt.List;
import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Iterator;
import java.util.LinkedList;
import java.util.Scanner;

public class Main {

    /**
     * @param args
     */
    public static class Student {
        String num;
        int n = 0;
        int score = 0;
    }
    
    public static class ComparatorStudent implements Comparator{

        @Override
        public int compare(Object arg0, Object arg1) {
            // TODO Auto-generated method stub
            Student student1=(Student)arg0;
            Student student2 = (Student)arg1;
            int flag;
            if(student1.score>student2.score){    
                flag=-1;
            }else if(student1.score==student2.score){
                flag =0;
            }else{
                flag=1;
            }
            if(flag==0){
                return student1.num.compareTo(student2.num);
            }else{
                return flag;
            }
        }
        
    }
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner in = new Scanner(System.in);
        while (true) {
            int N = in.nextInt();
            if (N == 0) {
                break;
            }
            int M = in.nextInt();
            int avg = in.nextInt();
            int[] eves = new int[M];
            for (int i = 0;i<M;i++){
                eves[i] = in.nextInt();
            }
            ArrayList<Student> L = new ArrayList<Student>();
            while(N!=0){
                N--;
                Student stu = new Student();
                stu.num = in.next();
                stu.n = in.nextInt();
                for (int i = 0;i<stu.n;i++){
                    int a =in.nextInt();
                    stu.score += eves[a-1];
                }
                L.add(stu);
            }
            int peo=0;
            ComparatorStudent comparator = new ComparatorStudent();
            Collections.sort(L,comparator);
            for (Student student : L) {
                if(student.score>=avg){
                    peo++;
                }
            }
            System.out.println(peo);
            for (Student student : L) {
                if(student.score>=avg){
                    System.out.println(student.num+" "+student.score);
                }
            }
            }
        }
    }


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章